Как превратить Raspberry Pi в защищенный VPN-роутер

Вы бы написали свой пароль на листе бумаги и приклеили его ко лбу? Возможно нет. Но подключаться к публичной сети Wi-Fi почти так же глупо.

У вас может не быть выбора, однако, если вы в дороге и хотите оставаться на связи. VPN может защитить вас, но каждое устройство должно подключаться отдельно, если вы не используете дорожный маршрутизатор в качестве посредника.

Нет под рукой? Не волнуйтесь, вы можете построить его с помощью Raspberry Pi. Это идеальный выбор для домашнего VPN-роутера для путешествий, поэтому давайте расскажем, как его создать.

Что вам понадобится

Чтобы приступить к созданию туристического маршрутизатора Raspberry Pi VPN , вам понадобится:

  • Raspberry Pi (предпочтительно Pi 3 или Raspberry Pi Zero W) в футляре.
  • Один USB-адаптер Wi-Fi (два, если вы используете более старую версию Raspberry Pi)
  • Карта microSD с объемом памяти не менее 8 ГБ.
  • Устройство чтения SD-карт.
  • Высококачественный источник питания.
  • ПК с установленным SSH-клиентом.
  • Подписка на VPN с поддержкой OpenVPN.

Можно использовать модели Pi без встроенного Wi-Fi, но вам понадобятся два USB-адаптера Wi-Fi или один, способный работать как в режиме управляемой точки доступа, так и в режиме клиента.

Вместо стандартного дистрибутива Linux вам необходимо установить OpenWRT на SD-карту, чтобы превратить его в полноценный роутер. Вы можете использовать другой дистрибутив Linux, если хотите, но OpenWRT предоставляет удобный веб-интерфейс для настройки, когда вы находитесь вдали от дома.

Если вы используете Windows, вам также необходимо установить PuTTY или другой клиент SSH для Windows, прежде чем вы начнете.

Шаг 1: Установите OpenWRT

Сначала загрузите прошивку OpenWRT для вашей модели Raspberry Pi. Вы можете найти самые свежие изображения в вики OpenWRT.

Разархивируйте загруженный файл с помощью 7zip или другого подходящего менеджера файловых архивов, затем прошейте файл IMG на карту с помощью Etcher.

Этот инструмент должен автоматически определять вашу SD-карту; вам просто нужно выбрать файл изображения, выбрать правильный диск по букве и затем щелкнуть Flash.

Как только это будет сделано, вставьте карту microSD обратно в Raspberry Pi и дайте ей загрузиться.

Шаг 2: Начальная конфигурация

По умолчанию OpenWRT использует статический IP-адрес 192.168.1.1 , который является IP-адресом шлюза по умолчанию для многих маршрутизаторов. Вам нужно будет изменить это, чтобы предотвратить конфликты. Подключите Pi к компьютеру с помощью кабеля Ethernet; вам может потребоваться сначала установить статический IP-адрес на вашем ПК.

Вместо того, чтобы обрабатывать конфигурацию с помощью LuCI, веб-интерфейса OpenWRT, вы собираетесь делать это вручную, чтобы убедиться, что конфигурация установлена ​​правильно. Загрузите PuTTY или ваш SSH-клиент и сначала подключитесь к 192.168.1.1 с именем пользователя root.

Вы получите начальное предупреждение системы безопасности при первом подключении; просто нажмите Да и продолжайте. На данном этапе рекомендуется установить пароль; сделайте это, набрав

passwd 

в окне терминала.

Настройте параметры сети и брандмауэра

Вам нужно отредактировать два файла —

 /etc/ config/network  

и

/etc/config/firewall 

— прежде чем продолжить. Начните с ввода следующего текста, чтобы отредактировать файл:

  vim/etc/config/network  

Затем нажмите I, чтобы отредактировать текст и включите следующее:

  config interface 'loopback' 
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option force_link '1'
option proto 'static'
option ipaddr '192.168.38.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wwan'
option proto 'dhcp'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4' # # DNS-серверы Google
config interface 'vpnclient'
option ifname 'tun0'
option proto 'none'

Когда вы закончите, нажмите клавишу Esc и введите

  :wq 

для сохранения и выхода. Затем переключите внимание на файл конфигурации брандмауэра:

  vim/etc/config/firewall  

Нажмите I для редактирования, затем найдите (или добавьте) зону для раздела WAN, которая должна выглядеть так:

  config zone 
имя параметра wan
option network 'wan wan6 wwan'
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

Введите reboot и подождите, пока Raspberry Pi перезагрузится с новым IP-адресом: 192.168.38.1 .

Шаг 3: Обновление и установка пакетов

Затем вам нужно обновить OpenWRT. Для этого вы собираетесь позаимствовать внутренний Wi-Fi Pi и изначально настроить его для подключения к существующей сети Wi-Fi. Возможно, вам потребуется изменить свой статический IP-адрес на 192.168.38.2 или аналогичный адрес в этом диапазоне, чтобы вы могли подключиться.

После подключения введите IP-адрес вашего Raspberry Pi в свой браузер, чтобы получить доступ к панели администратора OpenWRT. Используйте свое имя пользователя и пароль для получения доступа, затем перейдите в Сеть> Беспроводная связь . В настоящее время вы должны видеть только одно устройство Wi-Fi, поэтому нажмите Просканируйте , чтобы найти вашу сеть Wi-Fi, затем Присоединитесь к сети , когда найдете ее.

Вам нужно будет ввести свой пароль Wi-Fi в поле Кодовая фраза WPA , перед нажатием Отправить.

Теперь вы должны увидеть настройки подключения для вашего Wi-Fi-соединения. Перейдите в Расширенные настройки и установите Код страны в соответствии с вашим местоположением; иначе ваш Wi-Fi может не работать.

Повторно подключитесь к Pi, используя новый IP-адрес через SSH (принимая предупреждение ключа безопасности RSA). Сначала вам нужно обновить свое устройство, набрав:

  opkg update  

Следите за этим, нажав Y при появлении запроса.

Установка USB-драйверов Wi-Fi

После установки всех обновлений установите все необходимые драйверы для USB-адаптера Wi-Fi. Это необходимо для подключения к точкам доступа Wi-Fi, когда вы в пути. Вы также будете устанавливать инструменты, необходимые для VPN-подключений с использованием OpenVPN, а также nano , более простой в использовании редактор файлов терминала..

Здесь ваш метод может отличаться; У меня был адаптер Wi-Fi для набора микросхем RT2870, поэтому следующие команды должны работать, если вы тоже:

  opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-  rt2x00-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn nano 
ifconfig wlan1 up
перезагрузка

Если у вас нет адаптера Wi-Fi для набора микросхем RT2870 или вы не уверены, подключите адаптер Wi-Fi и введите в терминал SSH следующее:

  opkg install kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils 
lsusb

После установки файлов вы увидите список подключенных устройств. Найдите все, что относится к беспроводному адаптеру, и найдите соответствующие инструкции по установке для вашего устройства.

Шаг 4. Настройка точки доступа Wi-Fi

Если ваш USB-адаптер Wi-Fi подключен, теперь вы можете настроить оба соединения Wi-Fi. Вернитесь на панель управления LuCI в разделе , и удалите оба сетевых подключения. Устройство radio0 — это ваш встроенный Wi-Fi, а radio1 — это ваш USB-адаптер Wi-Fi.

Настройте встроенный Wi-Fi, нажав Добавить . Убедитесь в следующем:

  • Mode установлен на Точка доступа .
  • ESSID устанавливается на имя сети по вашему выбору; по умолчанию — OpenWRT.
  • Сеть установлен на lan
  • В Безопасность беспроводной сети , для Шифрование установлено значение WPA2-PSK
  • Ключ Установлен подходящий пароль.

Когда вы закончите, нажмите Сохранить , затем вернитесь к Wireless меню. Следуйте приведенным ранее инструкциям по первоначальному подключению, чтобы настроить устройство radio1 (ваш USB-адаптер Wi-Fi) на существующую сеть. Здесь также вам нужно сканировать и менять сети, когда вы находитесь в новом месте.

Теперь у вас должно быть запущено два соединения Wi-Fi, один в качестве точки доступа для ваших устройств Wi-Fi, а другой — для подключения вашего устройства к существующей сети Wi-Fi. Попробуйте на этом этапе подключение к Pi с помощью смартфона или ноутбука, чтобы убедиться, что оно работает.

Если это работает, отключите Pi от Ethernet-соединения с вашим ПК.

Шаг 5: Подключение к VPN и окончательные изменения

Вам понадобится файл конфигурации OpenVPN (OVPN), чтобы подключить Pi к выбранному вами провайдеру и серверу VPN. Если он у вас есть, загрузите его на свой Pi с помощью клиента SCP, такого как WinSCP, где вы можете подключиться со своим именем пользователя и паролем администратора.

Переименуйте файл в vpnclient.ovpn и загрузите его в

 /etc/openvpn  

папка. Следуйте инструкциям на веб-сайте OpenWRT, чтобы настроить Pi для VPN-подключений. Единственное небольшое изменение будет в разделе 4 для настройки профиля клиента VPN, где вам не нужно будет использовать начальный

cat 

инструмент для вставки файла vpnclient.ovpn , так как он уже на месте.

Как только вы это сделаете, ваше VPN-соединение должно активироваться автоматически. Убедитесь, что ваш исходящий IP-адрес изменился; если нет, перезагрузите Pi и убедитесь, что ваше соединение активно.

Найдите это, перейдя в раздел OpenVPN в LuCI, указанный в разделе Services вверху панели инструментов. Если он подключен, vpnclient будет указан как yes в столбце Запущено .

Шаг 6: Зарегистрируйте свое устройство в общедоступной сети Wi-Fi

На этом этапе ваш Pi почти готов, но если вы при подключении к общедоступной сети Wi-Fi вы будете знать, что обычно вам необходимо пройти аутентификацию с помощью адаптивного портала, чтобы оплатить или зарегистрировать свое устройство. Поскольку ваш Pi теперь настроен для автоматического подключения через VPN (и в противном случае должен предотвращать подключение), эти порталы обычно блокируются.

Чтобы обойти это, настройте USB-адаптер Wi-Fi на сопоставление MAC-адреса с устройством, которое вы можете использовать для подключения и аутентификации в первую очередь в общедоступной сети Wi-Fi, например, на вашем смартфоне. . Получив это, введите:

  nano/etc/init.d/wan-changer   

В окне редактирования добавьте следующее (заменив заполнитель XX для вашего MAC) и нажмите Ctrl + X, а затем Y , чтобы сохранить.

  #!/bin/sh/etc/rc.common 
START = 10
start () {
uci set wireless. @ wifi-iface [1] .macaddr = 'XX: XX: XX: XX: XX: XX'
сеть фиксации uci
}

Наконец, выполните следующие команды, чтобы сценарий запускался автоматически при запуске Pi:

  chmod + x/etc/init.d/wan-changer 
/etc/init.d/wan-changer enable

Перезагрузитесь, чтобы убедиться, что все работает нормально. Вы также должны проверить наличие утечек DNS, чтобы убедиться, что ваше VPN-соединение работает правильно. Большинство провайдеров VPN предлагают инструмент, который поможет в этом.

Безопасный Wi-Fi, куда бы вы ни пошли, гарантированно

Теперь ваш Raspberry Pi должен быть настроен и готов к работе в качестве туристического VPN-маршрутизатора, а это значит, что вы можете безопасно пользоваться серфингом в любом отеле или кафе, которое вы посещаете. Благодаря панели управления LuCI вы можете легко подключиться к любой новой сети Wi-Fi через веб-браузер.

Просмотрите наш список лучших VPN-сервисов, чтобы найти VPN-сервис, который соответствует вашим потребностям. Если это было слишком сложно для вас, вы также можете рассмотреть другие способы настройки VPN дома.

Оцените статью
cuterful.ru
Добавить комментарий